51牛股网 公式指标 通达信公式 大智慧公式 同花顺公式 飞狐公式 股票资讯 进阶学堂 炒股入门 公式使用技巧 免责声明

通达信战略家的操盘优化组合指标

来源:指标公式网(www.51niugu.cn) | 时间:2020-10-23 11:42:45 | 作者:指标公式网
龙头战法



这段时间湖北卫视猛吹的战略家,
其操盘原理和曹氏八线的持股线或凯恩斯的黄金线其实是一样的,不同的是,曹氏八线的持股线是15天均线,凯恩斯的黄金线是18天均线,而战略家的短线操盘线是10天均线,中线操盘线是45天均线而已。
而将其短线操盘和中线操盘组合在一起,再加上几条常用的均线,则要比战略家原版操盘公式实用得多。
下面是组合后的主图公式源码:
N:=IF(BARSCOUNT(C)>=10,10,BARSCOUNT(C));
STICKLINE(C>=MA(C,N),MA(C,N),REF(MA(C,N),1),5,0),COLORYELLOW;
STICKLINE(C<MA(C,N),MA(C,N),REF(MA(C,N),1),5,0),COLORBLUE;
DRAWTEXT(C>=MA(C,N) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,N),'   黄色持股  (短线)'),COLORYELLOW;
DRAWTEXT(C<MA(C,N) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,N),'   蓝色持币  (短线)'),COLORFF9933;
M:=IF(BARSCOUNT(C)>=45,45,BARSCOUNT(C));
STICKLINE(C>=MA(C,M),MA(C,M),REF(MA(C,M),1),5,0),COLORYELLOW;
STICKLINE(C<MA(C,M),MA(C,M),REF(MA(C,M),1),5,0),COLORBLUE;
{指标公式网-股票公式网站 WWW.51niugu.cn }
DRAWTEXT(C>=MA(C,M) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,M),'   黄色持股  (中线)'),COLORYELLOW;
{指标公式网-股票公式网站 www.51niugu.cn}
DRAWTEXT(C<MA(C,M) AND CURRBARSCOUNT=1 AND PERIOD=5,MA(C,M),'   蓝色持币  (中线)'),COLORFF9933;
DRAWKLINE(H,O,L,C);
MA5:MA(C,5),COLORMAGENTA;
MA10:MA(C,N),COLORLIRED;
MA25:MA(C,25),LINETHICK2,COLORRED;
MA45:MA(C,M),COLORGREEN;
MA120:MA(C,120),COLORBROWN;

另外,它的副图公式只偏重于短线操盘,我把慢速KD也组合进去后,也就兼顾了中线操盘。(慢速KD和MACD其实差不多,都是中线指标),
下面是组合后的副图公式,个人觉得比原版好用:
Z:=MA(C,120);
VAR3:=(MA(C,5)-Z)/Z;
VAR4:=MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);
波段进场:IF(CLOSE>Z AND REF(VAR4,1)<30 and="" var4="">REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2),80,50);
反弹进场:IF(REF(VAR4,1)<5 and="" var4="">REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) AND VAR3<-0.3,80,50);
超跌进场:IF(CROSS(VAR4,5) AND VAR3<-0.4,80,50); c="">=MA(C,10),VAR4,REF(VAR4,1),4,0),COLORRED;     STICKLINE(C<MA(C,10),VAR4,REF(VAR4,1),4,0),COLORGREEN;
RSV:= (CLOSE-LLV(LOW,50))/(HHV(HIGH,50)-LLV(LOW,50))*100;
FASTK:=SMA(RSV,3,1);
SK:SMA(FASTK,3,1),LINETHICK2,COLORYELLOW;
SD:SMA(SK,5,1),LINETHICK2,COLORMAGENTA;
MAKD:=(SK-SD)*2;
STICKLINE(MAKD>0 AND REF(MAKD,1)<MAKD,50,MAKD+50,0,0),COLORRED;
STICKLINE(MAKD>0 AND REF(MAKD,1)>MAKD,50,MAKD+50,0,0),COLORLIRED;
STICKLINE(MAKD<0 and="">MAKD,50,MAKD+50,0,0),COLORLICYAN;
STICKLINE(MAKD<0 AND REF(MAKD,1)<MAKD,50,MAKD+50,0,0),COLORLIGREEN;



本文地址:通达信战略家的操盘优化组合指标

上一篇:通达信快枪手指标

下一篇:通达信战略家蓝黄丝带主图指标

版权声明:

1、本网站发布的公式文章《通达信战略家的操盘优化组合指标》为51牛股网注册网友原创或整理,版权归原作者所有,转载请注明出处!

2、本网站公式/文章《通达信战略家的操盘优化组合指标》均出自网络,所有提供下载的软件和资源均为软件或程序作者提供和网友推荐收集整理而来,仅供学习和研究使用。如有侵犯你的版权,本站将立即改正,同时要求用户在24小时内删除

3、本网站一直无私为全国广大股友提供指标公式、股票文章,免费分享。对于不当转载或引用本网内容而引起的民事纷争、行政处理或其他损失,本网不承担责任。