51牛股网 公式指标 通达信公式 大智慧公式 同花顺公式 飞狐公式 股票资讯 进阶学堂 炒股入门 公式使用技巧 免责声明

殷保华主图加其他指标后压缩的解决

来源:指标公式网(www.51niugu.cn) | 时间:2020-10-23 11:44:33 | 作者:指标公式网
龙头战法


编写条件:


编写方法:

网友求助:

DRAWTEXT_FIX(C>0,0.004,1,0,DYBLOCK),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(C>0,0.06,1,0,HYBLOCK),COLORRED,LINETHICK2;
DRAWTEXT_FIX(C>0,0.12,1,0,EXTERNSTR(0,1)),COLORWHITE,LINETHICK2;
A1:=DATE <= 13181231;
七:MA(C,7),COLORGRAY;
十四:(EMA(C,14)) * A1,POINTDOT,LINETHICK4,COLORYELLOW;
二五:(MA(C,21)) * A1,LINETHICK2,COLORMAGENTA;
四三:(MA(C,43)) * A1,COLORCYAN;
五十六:(EMA(C,56)) * A1,COLORWHITE;
九九:(EMA(C,99))*A1,COLORBLUE;
年:(EMA(C,250))*A1,COLORRED;
A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
A4:=EMA(C,10);
A5:=REF(C,2);
A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C - A5)),6,1))) * 100;
A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
A8:=LLV(L,21);
A9:=HHV(H,21);
A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
A13:=LLV(L,55);
A14:=HHV(H,34);
A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
A16:=(A11 + A15) / 2;
A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
A18:=EMA(A16,5);
A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
A20:=CROSS(A10,A11);
A21:=(CROSS(A10,A19)) AND (A19 < 30);
A22:=A21 * 0.6;
A23:=((C + L) + H) / 3;
A24:=EMA(A23,6);
A25:=EMA(A24,5);
A26:=CROSS(A24,A25);
DRAWICON(A26,(LOW / 1.015),1),LINETHICK2,COLORMAGENTA;
DRAWTEXT(CROSS(A4,A3),L*0.9,'上阴买!下阳卖!'),LINETHICK4,COLORYELLOW;
STICKLINE(((C >= 十四) AND (C >= O)),H,L,0,1),COLORRED;
STICKLINE(((C >= 十四) AND (C >= O)),O,C,2,1),COLORRED;
STICKLINE(((C >= 十四) AND (C <= O)),H,L,0,0),COLORRED;
STICKLINE(((C >= 十四) AND (C <= O)),O,C,2,0),COLORRED;
STICKLINE(((C < 十四) AND (C >= O)),H,L,0,1),COLORGREEN;
STICKLINE(((C < 十四) AND (C >= O)),O,C,2,1),COLORGREEN;
STICKLINE(((C < 十四) AND (C <= O)),H,L,0,0),COLORGREEN;
STICKLINE(((C < 十四) AND (C <= O)),O,C,2,0),COLORGREEN;


JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
STICKLINE(A>B,A,B,5,0),COLORYELLOW;
STICKLINE(A<B,A,B,5,0),COLORBLUE;
{超赢天下};


源码加了下面这段源码后主图就压缩的厉害,摸索了半天也没用解决,求老师帮忙。
C7:=CROSS(C,MA(C,7));
C25:=CROSS(C,MA(C,25));
C60:=CROSS(C,MA(C,60));
AA1:=MA(CLOSE,7);
AA2:=MA(CLOSE,14);
AA3:=MA(CLOSE,25);
DT:=COUNT(AA1>AA2 AND AA2>AA3 ,3)=3;
DRAWTEXT(C7 AND DT,L*0.91,'穿7'),COLORYELLOW;
DRAWTEXT(C25 ,L,'潜伏'),COLORYELLOW;
DRAWTEXT(C60 ,L*0.92,'中奖'),COLORYELLOW;

AA:EMA(C,3),COLOR000000;
BB:EMA(C,8),COLOR000000;
小秘密:CROSS(BB,AA),LINETHICK0;
DRAWTEXT(小秘密,L*0.89,'跟进'),COLORF00FF0;
{蜘蛛潜伏和小秘密};

解答如下:
DRAWTEXT_FIX(C>0,0.004,1,0,DYBLOCK),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(C>0,0.06,1,0,HYBLOCK),COLORRED,LINETHICK2;
DRAWTEXT_FIX(C>0,0.12,1,0,EXTERNSTR(0,1)),COLORWHITE,LINETHICK2;
A1:=DATE <= 13181231;
七:MA(C,7),COLORGRAY;
十四:(EMA(C,14)) * A1,POINTDOT,LINETHICK4,COLORYELLOW;
二五:(MA(C,21)) * A1,LINETHICK2,COLORMAGENTA;
四三:(MA(C,43)) * A1,COLORCYAN;
五十六:(EMA(C,56)) * A1,COLORWHITE;
九九:(EMA(C,99))*A1,COLORBLUE;
年:(EMA(C,250))*A1,COLORRED;
A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
A4:=EMA(C,10);
A5:=REF(C,2);
A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C - A5)),6,1))) * 100;
A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
A8:=LLV(L,21);
A9:=HHV(H,21);
A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
A13:=LLV(L,55);
A14:=HHV(H,34);
A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
A16:=(A11 + A15) / 2;
A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
A18:=EMA(A16,5);
A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
A20:=CROSS(A10,A11);
A21:=(CROSS(A10,A19)) AND (A19 < 30);
A22:=A21 * 0.6;
A23:=((C + L) + H) / 3;
A24:=EMA(A23,6);
A25:=EMA(A24,5);
A26:=CROSS(A24,A25);
DRAWICON(A26,(LOW / 1.015),1),LINETHICK2,COLORMAGENTA;
DRAWTEXT(CROSS(A4,A3),L*0.9,'上阴买!下阳卖!'),LINETHICK4,COLORYELLOW;
STICKLINE(((C >= 十四) AND (C >= O)),H,L,0,1),COLORRED;
STICKLINE(((C >= 十四) AND (C >= O)),O,C,2,1),COLORRED;
STICKLINE(((C >= 十四) AND (C <= O)),H,L,0,0),COLORRED;
STICKLINE(((C >= 十四) AND (C <= O)),O,C,2,0),COLORRED;
STICKLINE(((C < 十四) AND (C >= O)),H,L,0,1),COLORGREEN;
STICKLINE(((C < 十四) AND (C >= O)),O,C,2,1),COLORGREEN;
STICKLINE(((C < 十四) AND (C <= O)),H,L,0,0),COLORGREEN;
STICKLINE(((C < 十四) AND (C <= O)),O,C,2,0),COLORGREEN;

JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);
STICKLINE(A>B,A,B,5,0),COLORYELLOW;
STICKLINE(A<B,A,B,5,0),COLORBLUE;
{超赢天下};
C7:=CROSS(C,MA(C,7));
C25:=CROSS(C,MA(C,25));
C60:=CROSS(C,MA(C,60));
AA1:=MA(CLOSE,7);
AA2:=MA(CLOSE,14);
AA3:=MA(CLOSE,25);
DT:=COUNT(AA1>AA2 AND AA2>AA3 ,3)=3;


DRAWTEXT(C7 AND DT,L,'穿7'),COLORYELLOW;
DRAWTEXT(C25 ,L,'潜伏'),COLORYELLOW;
DRAWTEXT(C60 ,L,'中奖'),COLORYELLOW;

AA:=EMA(C,3),COLOR000000;
BB:=EMA(C,8),COLOR000000;
小秘密:=CROSS(BB,AA),LINETHICK0;
DRAWTEXT(小秘密,L,'跟进'),COLORF00FF0;
{蜘蛛潜伏和小秘密};


本文地址:殷保华主图加其他指标后压缩的解决

上一篇:通达信宝华均线主图指标

下一篇:把殷保华的公式改为通达信

版权声明:

1、本网站发布的公式文章《殷保华主图加其他指标后压缩的解决》为51牛股网注册网友原创或整理,版权归原作者所有,转载请注明出处!

2、本网站公式/文章《殷保华主图加其他指标后压缩的解决》均出自网络,所有提供下载的软件和资源均为软件或程序作者提供和网友推荐收集整理而来,仅供学习和研究使用。如有侵犯你的版权,本站将立即改正,同时要求用户在24小时内删除

3、本网站一直无私为全国广大股友提供指标公式、股票文章,免费分享。对于不当转载或引用本网内容而引起的民事纷争、行政处理或其他损失,本网不承担责任。